Entradas

Cisco VPN Windows 8

Ingresamos  al Registro de Windows al siguiente Path HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CVirtA al ingresar a modificar el registro encontraremos  @oem8.inf,%CVirtA_Desc%;Cisco Systems VPN Adapter for 64-bit Windows  to  Cisco Systems VPN Adapter for 64-bit Windows Borraremos estos caracteres @oem8.inf,%CVirtA_Desc%; Cisco Systems VPN Adapter for 64-bit Windows  to  Cisco Systems VPN Adapter for 64-bit Windows el registro nos quedara así: Cisco Systems VPN Adapter for 64-bit Windows  to  Cis co Systems VPN Adapter for 64-bit Windows para finalizar reiniciaremos la Computadora.

Instalar GNS3 0.8.2, Dynamips 0.2.8-RC3 y Qemu 0.11 en Ubuntu 12.04

Imagen
Si queremos instalar GNS3 0.8.2 en Ubuntu 11.10  podemos seguir los siguentes manuales: http://www.openredes.com/2012/05/03/instalar-gns3-0-8-2-dynamips-0-2-8-rc3-y-qemu-0-11-en-ubuntu-11-10-oneiric-ocelot/ http://forum.gns3.net/topic4690.html http://forum.gns3.net/topic4692-20.html http://www.kartook.com/2012/04/how-to-install-and-configure-gns3-v0-8-2-ubuntu-11-10-x64/

Comprimir directorio desde consola y excluir subdirectorios

Un  comando de consola o terminal  muy simple pero muy útil en  Linux para comprimir directorios completos  es el archiconocido “tar” con el que podemos comprimir directorios y hacer backups de forma mas sencilla. Con el comando: tar -zcvf nombre-nuevo-archivo-comprimido.tar.gz /ruta/directorio-a-comprimir Pero si queremos  comprimir un directorio excluyendo alguno de sus subdirectorios  el comando sería: tar -zcvf nombre-nuevo-archivo-comprimido.tar.gz --exclude='/ruta/directorio-a-comprimir/subdirectorio-a-excluir' --exclude='/ruta/directorio-a-comprimir/subdirectorio-a-excluir-2' /ruta/directorio-a-comprimir Fuente http://www.openredes.com/2012/09/14/comprimir-directorio-desde-consola-y-excluir-subdirectorios/

Detectar ataque DOS en nuestro servidor web

¿Tu servidor web está sobrecargado y no sabes por qué? ¿Crees estar bajo un  ataque de denegación de servicio ? Si estas son tus sospechas aquí tienes un útil comando que te muestra el número de conexiones concurrentes por IP que se están llevando a cabo en tu servidor web: netstat -plan|grep :80|awk {'print $5'}|cut -d: -f 1|sort|uniq -c|sort -nk 1 Si quieres saber como funcionan los ataques DoS y DDoS  aquí  tienes un interesante artículo de Vinagre Asesino Fuente: http://www.openredes.com/2012/10/21/detectar-ataque-dos-en-nuestro-servidor-web/

Instalar un servidor PXE en nuestra red local

En esta entrada vamos a explicar paso a paso la instalación de un  servidor PXE   (Preboot Execution Environment)  en nuestra red para que nos sirva de repositorio de imágenes de SSOO con los que poder arrancar  ThinClients  por red sin que necesiten almacenar el SO en disco. En este caso usaré una  máquina virtual  con  Linux Mint 10 (Julia)  que tengo instalada en un  server ESXi 3.5  en la que voy a instalar los servicios necesarios para convertirla en  server PXE , que básicamente son un  servidor DHCP  y un servidor  TFTP . Instalamos el servidor DHCP en nuestra VM Julia: root@ricardo:~# apt-get install dhcp3-server Configuramos el servidor dhcp editando los archivos /etc/default/dhcp3-server y /etc/dhcp3/dhcp.conf: /etc/default/dhcp3-server: Editamos este archivo configurando la interfaz de escucha por la que los clientes solicitan una IP: ... INTERFACES="eth0" … En mi caso la interfaz e...

Direcciones IPv4 privadas y de propósito especial

Imagen
Recojo aquí un  artículo  publicado en el blog  CCIE en español  que resume de forma esquemáticas los  bloques de direcciones Ipv4 reservados  para propósitos especiales por  IANA  y que me parece bastante interesante tenerlo almacenado en la sección  Apuntes  de  openredes . Recientemente fueron publicados los  RFC   5735 ,  5736  y  5737  que básicamente entregan el listado de direcciones  IPv4  asignadas por  IANA  para propósitos especiales (dejando obsoleto el  RFC 3330 ). Estás se pueden ver en la siguiente tabla (extracto del  RFC 5735 ): Address Block Present Use Reference ------------------------------------------------------------------ 0.0.0.0/8 "This" Network RFC 1122, Section 3.2.1.3 10.0.0.0/8 Private-Use Networks RFC 1918 127.0.0.0/8 Loopback RFC 1122, Section ...

Error “user is not in the sudoers file. This incident will be reported.” Habilitar permiso de ejecución de sudo

El error  user is not in the sudoers file. This incident will be reported . en máquinas  Linux basadas en Debian  ocurre cuando tratamos de ejecutar una orden de root por consola usando  sudo  con otro usuario del sistema y éste no está reflejado en el archivo  /etc/sudoers   como usuario con permisos para usar sudo . Para solucionar esto basta con añadir la línea siguiente en el archivo  /etc/sudoers  especificando el nombre del usuario al que queremos dar permiso de uso de  sudo : username ALL=(ALL) ALL Para modificar el archivo  /etc/sudoers  podemos hacerlo como root usando cualquier editor de texto, con el comando echo o, como manda Debian usando  visudo , por que  visudo ? porque es mucho más seguro como veremos después. Al usar  visudo  se abre el archivo  /etc/sudoers  con el editor de texto que haya configurado por defecto en el sistema, si no lo hemos cambiado será  vi  qui...